Sign in to follow this  
ggm_58

[Help]Installation C&C Generals Edition Delux

28 posts in this topic

Bonjour à tous!

Soldats, vous êtes mon dernier recours!

Il y a quelques temps un pote m'avais passé C&C Generals. Ce fut une claque, et de bonne partie de LAN (sur Windows XP)! A la suite d'un formatage, j'ai perdu toutes mes données, le pote avait revendu son exemplaire, bref, je suis passé à autre chose.

L'autre jour, en me baladant à la Fnac, j'ai repéré cette édition "Deluxe", à pas cher. Hop, je l'ai pris, je me revoyais déjà en train de promener mon tracto-pelle pour faire du "boulot made in USA", mais que neni!...

Je m'explique : j'installe "Command & Conquer" CD1, puis CD2... Pas de problèmes.

J'installe ensuite l´extension "Generals", CD1 ok, CD2... et là, mauvaise surprise ; un des fichiers sur le CD est endomagé! (oO") (fichier "langage.cab") Sig!

message_d_erreur.jpg

Le cd est pourtant nickel, pas de rayure, pas de traces, rien... J'ai essayé plusieurs fois d'installer, mais rien n'y fait...

J'ai rapporté le cd à la fnac, j'ai fait changer les cd par d'autres exemplaires neufs sous blister... Et pan... Même problème... Vraiment pas d'bol.

Et cerise sur le gâteau : je me suis mis dans l'idée de jouer, à défaut, à Command & Conquer sans extension, et là... pan :

message_d_erreur_2.jpg

Ça doit être à cause de Windows 7 je pense... Parce que je l'ai installé sur mon ancien pc sur XP, et là, ça fonctionne...

ah, au fait, j'ai scanné la jaquette au cas où il y ai des infos utiles dessus :

jaquette_001.jpg

Enfin, voilà, j'ai contacté l'éditeur, pas de réponses... J'espère que vous pourrez m'aider, à savoir si ce problème s'est déjà présenté à vous...

Merci à vous!

Edited by ggm_58

Share this post


Link to post
Share on other sites

Je pense que le meilleur moyen serait de copier le fichier langage.cab de quelqu'un qui a déjà Generals et de remplacer le tiens avec. Mais attention, ça DOIT être une version de manque langue que la tienne, sinon ça risque fort de planter encore.

Share this post


Link to post
Share on other sites
Je pense que le meilleur moyen serait de copier le fichier langage.cab de quelqu'un qui a déjà Generals et de remplacer le tiens avec. Mais attention, ça DOIT être une version de manque langue que la tienne, sinon ça risque fort de planter encore.

Ce serait possible si l'installation se finalisait, mais c'est lors de l'installation que ça bug... ça annule tout!

Je pense plutot qu'il me faudrait une image de cd sur laquelle je rentrerais mes propres clefs! C'est quand même un comble!

Et pour mon soucis avec C&C normal? Il faut que je pique le dossier jeu de C&C correctement installé sur XP et je remplace avec sur windows 7?...

Share this post


Link to post
Share on other sites

Si t'a un 2eme lecteur CD, essaie avec, il arrive que lorsque qu'un lecteur CD/DVD est un peu fatigué, il ai des réactions bizarres sur les CD meme nouveaux.

J'avais un jeu qui refusait catégoriquement de s'installer avec mon lecteur CD/DVD alors que le vieux simple CD y arrivait sans problemes.

(c'est pour ca que je garde cette relique dans ma tour, pour les quelques récalcitrants du CD/DVD)

Edited by Atlantis

Share this post


Link to post
Share on other sites

Quelqu'un pourrait me filer une copie de ce satané fichier "langage.cab" pour heureH? Une version non abîmée!

J'arrête pas de bricoler pour installer ce foutu CD, mais rien y fait, d'où que vienne la version d'installation (-_-), j'ai ce foutu message d'erreur "fichier langage.cab introuvable", bla, bla, bla... J'hallucine quand même! Ne me dites pas que les 3/4 des éditions deluxe merdent à ce point dans le monde, qu'il soit impossible de trouver un fichier langage.cab qui tienne à peu près la route!!

Incroyable... Je ne pensais pas être emm** à ce point en achetant ce jeu sous blister, neuf, et qui a été édité il y a des années... franchement, ça fait réfléchir...

Edited by ggm_58

Share this post


Link to post
Share on other sites

Ben dans la mesure où j'ai déjà échange mon premier exemplaire neuf moisit par un second autre exemplaire neuf moisit, je peux bien racheter des jeux neufs jusqu'à la fin de mes jours, ça n'avancera pas le schmilblik!... Ou alors je suis vraiment le pire des poissards!

Désolé, je m'emporte, mais bon, c'est quand même frustrant d'acheter un jeu neuf pour être tranquille, et finalement être obliger de bidouiller en prenant des morceaux par ci par là, pire que si j'avais choppé une version chraquée!

Edited by ggm_58

Share this post


Link to post
Share on other sites

Bon... Bonne nouvelle! (enfin!)

J'ai... récupéré une autre édition que mes deux CD, mais cela posait toujours problème.

En fait, en insérant le CD1, le setup recherche le fichier "langage.cab"... Ca c'est sûr, il ne risquait pas de le trouver, vu qu'il est sur le CD2!!

J'ai décompressé le CD1, et le CD2 sur mon disque dur, puis j'ai copier le fichier "langage.cab" du dossier décompressé CD2 vers le dossier décompressé CD1, lancé le setup dans celui-ci...

et hop comme une lettre à la poste!! Miracle. Alors? On a retrouvé son âme de général? Ben pas vraiment en fait...

Vlan!

MESSAGE_D_ERREUR.jpg

Mais bon... On va pas faire la fine bouche, hein : on s'oriente vers le mieux... Reste "plus qu'à" résoudre ce problème de compatibilité...

-_-

Share this post


Link to post
Share on other sites

Alors tout d'avord, mes excuses pour le tri... euh, non, quadruple post... :mad:

Mais voilà, j'ai résolu mon problème et j'aimerais partager ma solution (pas très orthodoxe) avec mes compagnons de galère qui ont aussi des problèmes de compatibilité.

J'ai ré installé Generals et Generals heureH sur mon vieux PC sous XP.

Une fois tout le ramdam installé, en passant par un réseau domestique, j'ai remplacé les dossiers "Command & Conquer Generals - Heure H" et "Command and Conquer Generals" sur mon pc sous 7, par leurs homologues sous XPqui sont dans Program Files. J'ai aussi configuré les raccourcit pour les exécuter en compatibilité XP s3.

Ensuite, j'ai fait de même avec les dossiers "Command & Conquer Generals - Heure H Data" et "Command and Conquer Generals Data" (voir dans "mes Documents") : j'ai écrasé la version 7 par leur équivalents sous XP...

Et là Maaagie!

L'application s'est lancée correctement. A présent, il ne reste plus qu'à tester tout ça dans la durée...

Edited by ggm_58

Share this post


Link to post
Share on other sites

Fais attention car même sous XP ce message apparait, c'est assez fréquent (et même automatique sur certaine carte pour moi).

Share this post


Link to post
Share on other sites

Nan mais je pense qu'il a eu le même bug que moi avant que je remplace les dossiers de jeu qui s'installaient mal : c'est-à-dire un plantage au lancement même du jeu.

Share this post


Link to post
Share on other sites

Il semblerai que l'imbécile en charge de la création de l'installateur se soit planté.

Souvent les éditeurs de réedition pas cher se sentent obligé de packager le jeu avec leur merde, genre club bidule.

C'est agaçant.

Share this post


Link to post
Share on other sites

C'est clair, c'est même frustrant...

Bon, sinon, je touche le saint graal, mais je n'en ai hélas qu'un aperçu... Quand je lance une partie, quoique je fasse, ma base, mes bâtiments etc... s'auto-détruisent. J'ai lu ça et là que ça arrivais à d'autres... Bon... avant de faire du "Command & Conquer", il va falloir encore faire du "Cherche & Bidouille"...

Share this post


Link to post
Share on other sites

Surement parce que tu n'as fait que un copier coller des dossiers et pas des clés dans la base de registre.

Note : Ne fais surtout pas un copier coller de la base de registre...

Share this post


Link to post
Share on other sites

Mmm... Comment j'vais m'en sortir moi... C'est quand même curieux comme symptôme, non?

Edit : Bon, j'ai pas ce problème avec Generals.

Edited by ggm_58

Share this post


Link to post
Share on other sites

D'accord, je vois... Le problème ne viens pas du numéro de licence, mais viens de l'installation elle même. Compris! >] hin hin hin!

Edit :C'est bon, je me suis dépatouillé... :rolleyes:

Merci beaucoup pour vos conseils et vos liens, je vous en suis sincèrement reconnaissant! :)

Edited by ggm_58

Share this post


Link to post
Share on other sites

Salut l'ami,

pour ma part j'ai mis la compatibilité en windows 2000 et en tant qu'administrateur pour le c&c générals et le jeu se lance sans prob. Et j'ai le même souci que toi avec le "langage.cab" je tente de tout copier et voir.

merci

Share this post


Link to post
Share on other sites

j'ai, moi aussi acheté GEN DELUXE ( avec CnC4)

Generals s'est installé nickel, j'ai installé que le CD1.

et il fonctionne QUE avec le CD.

Perso, je n'ai pas de fichier se nommant "langage.cab"

et le jeu fonctionne bien.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this